Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

AROS only sees apx. 7.5 GB of a 500 GB HDD

Last updated on 12 days ago
Amiwell79Amiwell79Distro Maintainer
Posted 12 days ago
at the moment 7.5 Gb may be enough aros does not take up that much space
Amiwell79Amiwell79Distro Maintainer
Posted 12 days ago
thank you at least now we know that the sata implementation works even if it has limitations at the moment
Edited by Amiwell79 on 11-02-2024 16:32, 12 days ago
D
deadwoodAROS Dev
Posted 12 days ago
FYI, I confirmed this issues and created a bug report for it:

https://github.com/deadwood2/AROS/issues/135
Amiwell79Amiwell79Distro Maintainer
Posted 15 days ago
you can use a usb key installation also
D
deadwoodAROS Dev
Posted 15 days ago
Hmm, I didn't pay attention when doing test installs on AHCI last week. I will repeat these tests to see if this happens on my configurations as well.
S
StudenteerJunior Member
Posted 15 days ago

deadwood wrote:

@deadwood -

Studenteer wrote:

@Studenteer
The "ahci.device"-problem seems to be related to driver. ANY Computer I had ever installed AROS at least once got those problems when installing on AHCI.


So this is not repeatable? I mean on the same configuration one installation process will use whole disk and the other process will be locked at 7.5GB?


This issue is repeatable with every computer with AHCI - with the configuration of Puni's computer or any other computer.

Like I said, it is like AROS do not know, that there is more space left then 7.5 GB - no forcing, no work around, just those 7.5 GB avaible (also with the computers of "recommened hardware"). No possiblitly to gain full access to storage-capacity, while running AHCI.

EDIT: As it seems, AROS can see partitions larger then 7.5 GB though AHCI, but it have no option to use those. The storage capacity over 7.5 GB still left untouched.
Edited by Studenteer on 09-02-2024 05:04, 15 days ago
D
deadwoodAROS Dev
Posted 15 days ago

Puni wrote:

@Puni If you are interested Deadwood, I can post the specs of the computer here along with the error message I receive? Thanks for the help so far. :-)


No need right now - I will try to reproduce this problem on test hardware I have.
D
deadwoodAROS Dev
Posted 15 days ago

Studenteer wrote:

@Studenteer
The "ahci.device"-problem seems to be related to driver. ANY Computer I had ever installed AROS at least once got those problems when installing on AHCI.


So this is not repeatable? I mean on the same configuration one installation process will use whole disk and the other process will be locked at 7.5GB?
S
StudenteerJunior Member
Posted 15 days ago

deadwood wrote:

@deadwood - Let me know if switching to ata.device solves your issues. That would be weird and definatelly something to look into - there shouldn't be such limitation on ahci.device.

(...)

One other thing you could try is during InstallAROS instead of letting AROS use "whole" size of disk, force it to use something like 120GB. If I recall correctly it is possible that AROS has 128GB partition size limit so your whole disk won't be used anyhow.


The "ahci.device"-problem seems to be related to driver. ANY Computer I had ever installed AROS at least once got those problems when installing on AHCI. Every time facing this bug, it seems like AROS do not know, that there is more space left, when AHCI is activated.

Because of this issue of approx. 7.5 GB space while more available, I recommening to avoid AHCI as driver as possible.
PuniPuniNewbie
Posted 15 days ago
Unfortunately, the BIOS does not allow (it does not even have the option) to switch to SATA/IDE. The laptop is from HP. I checked customer service and this is one of many laptops HP has released that has this restriction. I got an error message when I tried to force it to use a specific size. I think I will use this machine for another project and find a more suitable one for AROS. :-) If you are interested Deadwood, I can post the specs of the computer here along with the error message I receive? Thanks for the help so far. :-)
D
deadwoodAROS Dev
Posted 16 days ago
One other thing you could try is during InstallAROS instead of letting AROS use "whole" size of disk, force it to use something like 120GB. If I recall correctly it is possible that AROS has 128GB partition size limit so your whole disk won't be used anyhow.
D
deadwoodAROS Dev
Posted 16 days ago
Let me know if switching to ata.device solves your issues. That would be weird and definatelly something to look into - there shouldn't be such limitation on ahci.device.
PuniPuniNewbie
Posted 16 days ago
Thanks for the helpful information. You are correct in that I'm running AHCI. I will try what you suggested! Like Cheers!
S
StudenteerJunior Member
Posted 16 days ago
Sounds like you running your storage on AHCI.
For fixing it, you should check in your BIOS-Settings, if you can switch your mode of handling internal disk from AHCI to SATA or IDE. If possible, select SATA or IDE-Mode and reinstall AROS. After that, you should gain full storage capacity. Note, that your datas saved on your harddisk before will be lost - so a reinstallation of AROS will be nessacary.
PuniPuniNewbie
Posted 16 days ago
Hi,

A beginner with AROS here.

I managed to install AROS on a laptop. Unfortunately I can't get it to see more than apx. 7.5 GB of the HDD's size. The original size of the HDD is 500 GB. It had Linux (Peppermint) on it from before, but wiped the disk (using the AROS Installer tool), so it should all be gone. I've also used HDToolbox to try to partition it manually, but only about 7.5 GB of free space shows up there as well. Any ideas? Thanks in advance! Smile
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Moderator: Administrator
Users who participated in discussion: deadwood, Amiwell79, Studenteer, Puni
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 7
Members Online 0

Total Members: 209
Newest Member: Methanoid
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]