Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

AROS ABIv0 20211128

Last updated on 3 months ago
D
deadwoodAROS Dev
Posted 4 months ago
Hi,

New build and some good news. I was able to upgrade the base system to the final version already, so 20211128. This means that following builds should only contain small changes and bug fixes, rather then updates to all components. Note that I still didn't perform full regression testing, this will happen once I get contrib updated to new version.

https://axrt.org/development/AROS-20211128-D05-pc-i386-boot-iso.zip

Worth noting there are more fixes to Wanderer. @AMIGASYSTEM please check if this bug is resolved https://github.com/deadw00d/AROS/issues/47

Change log:

AROS ABIv0 20211128-D05 changes:

 KNOWN ISSUES:
 Warm reboot does not work under VirtualBox and QEMU
 No mouse pointer when booting in VESA mode from AROS Live Drive ( Live USB )
 Keymap files for Italian, French, Polish are broken
 Device name missing in InstallAROS in case of AHCI

 Functionalities:
 Extensions to IO-APIC support in Kernel (Kalamatee)
 Allow ejecting AHCI media (Kalamatee)
 Initial work on nvme.device (Kalamatee)
 Added support for message signalled interrupts (Kalamatee)
 Rework ECAM support in pci.hidd (Kalamatee)
 Allow forcing AHCI generation via boot parameters (Kalamatee)
 processor.resource supports checking availability of AVX, HyperV, AES (Kalamatee)
 Decrease usage of C standard library functions in AROS libraries (Matthias Rustler)
 Tool for debugging AROS under HyperV (Kalamatee)
 Improved SetMem using SSE, implemented SetMem using AVX (Kalamatee)
 Migrated keymaps to new format (Kalamatee)
 Made InstallAROS better at detecting suitable drives (Kalamatee)
 Initial work on wide character support in C library (Kalamatee)
 Multiple improvements to copy and delete in Wanderer (Bo Kopperud)
 Implemented C++ startup objects (Kalamatee)
 Show disassembly of failing code in Alerts (Kalamatee)
 Improvements in handling themes and Prefs/Appearance (Kalamatee)
 Enabled structural unit testing (Kalamatee)

 Updates:
 AROS build system (Kalamatee)
 Documentation (Matthias Rustler)
 BoingIconBar (20230501) (Kalamatee)
 ahci.device v0.04 (Kalamatee)
 Boot/No disk present animation (Kalamatee)
 SysExplorer v0.13 (Kalamatee)
 acpi.library 20201113 (Kalamatee)
 z library (Kalamatee)
 png.library v53.1 (Kalamatee)
 jpeg library v9d (Kalamatee)
 freetype2.library v6.4 (Kalamatee)
 jpeg.datatype v41.1 (Miker)

 Functional fixes:
 AROS Build system (Kalamatee, David Gilmore, Marlon Beijer)
 Allow loading old-style ELF keymaps (deadwood)
 Revert to using ISO-8859-2 for polish (deadwood)
 muimaster.library (bugs: notifications issues when 'new==old' for certains attributes) (deadwood)
 Register.mui (bugs: labels don't support escape sequences) (deadwood)
 InstallAROS (bugs: windows entry not added to grub config) (deadwood)
 ahci.device (bugs: wrong total size reported) (Kalamatee)
 USB (bugs: race condition with input.device) (Kalamatee)
 datatypes.library (bugs: ASCII not recognized) (Matthias Rustler)
 i8042.hidd (bugs: direct use of hardware, lockups on HyperV, log delay on some hardware) (Kalamatee, deadwood)
 C library (access, execl, vfork, fseek) (Kalamatee, Matthias Rustler)
 wav.datatype (Kalamatee)
 locale.library (bugs: broken condition in OpenLocale, wrong behavior in FormatString) (Kalamatee)
 Prefs/Input (bugs: broken condition) (Kalamatee)
 InstallAROS (improved stack usage) (Kalamatee)
 dos.library (bugs: loading of large C++ binaries fail, wrong order when calling MatchFunc) (Kalamatee, deadwood)
 hdaudio.audio (Kalamatee)
 Wanderer (bugs: buffer overruns) (Matthias Rustler)
 Prefs/IControl (fixed layout) (Kalamatee)
 Workbook (Thomas Scheller)
 graphics.library (bugs: wrong behavior of ClipBlit in some cases) (JuanDoble07)
 intuition.library (added support for labels in propgadget) (JuanDoble07)
 gadtools.library (fixed behavior of TEXT gadget) (JuanDoble07)

 Stability fixes:
 ImageAdjust.mui (arkade, Kalamatee)
 ata.device (Kalamatee)
 Prefs/ScreenMode (Kalamatee)
 intuition.library (Kalamatee)
 ilbm.datatype (Kalamatee)
 C:TaskList (Kalamatee)
 vesagfx.hidd (Kalamatee)
 exec.library (Kalamatee)
 processor.resource (Kalamatee)
 Prefs/Printer (Matthias Rustler)
 ram-handler (Matthias Rustler)
 dos.library (Ronnie Beck, JuanDoble07)

 64-bit/68k/ARM support:
 Fix 8 byte copy for AC080 (Kalamatee)
 Support AVX context save/restore. Report availability. (Kalamatee)
 Fix building of diskimage.device for ARM targets (Kalamatee)
 Add startup code to handle ARM EABI unwinding in binaries (Kalamatee)
 Enable SSE on 64-bit Mesa builds (Kalamatee)
 64-bit fixes for CMI8738 and VIA-AC97 drivers (Kalamatee)
 Fixes for booting from disk on 64-bit system (Kalamatee)
 Support for SAGA chipset (Ronnie Beck)
 Support AMMX in m68k kernel (Ronnie Beck)
 Performance improvements in amigavideo.hidd (Ronnie Beck)
 Support for SD card on Vampire cards (Ronnie Beck)
 Binary interfaces fixes in graphics.library (JuanDoble07)
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago
Ok thanks deadwood, I'll do all the necessary tests!

Reguard "No mouse pointer when booting in VESA mode from AROS Live Drive ( Live USB )!" what are you referring to,

On the USB Pendrive either installed from InstallAROS, or from the Script that generates the USB Pendriver to Install AROS, it has no problems on the Pointer on my ACER Aspire One ZG5, whether in VESA mode or Graphics Sheda mode

In the previous post the link you attached to user d0wz, does not work because at the end of the link there is a dot (.)
D
deadwoodAROS Dev
Posted 4 months ago
Hmm, I don't see . on the link. Both links (one to the github and one to the 64-bit ISO) work for me.

With regards to "no mouse pointer" regression, this is something that I see consistently on my test computer. It's very weird problem. It's only in VESA/VGA modes when running from pen drive. Once I install AROS to hard drive, the then problem goes away.
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago

deadwood wrote:

@deadwood - Hmm, I don't see . on the link. Both links (one to the github and one to the 64-bit ISO) work for me.
.

OK, now it works for me too, this morning I had to delete the full stop final (.) otherwise I had a blank 'site not found' page !!!

Quote


With regards to "no mouse pointer" regression, this is something that I see consistently on my test computer. It's very weird problem. It's only in VESA/VGA modes when running from pen drive. Once I install AROS to hard drive, the then problem goes away.


With these last two of your Builds D1 and D2 the Live Pendrive works fine (Mouse arrow visible) on my PCs "ACER Aspire One ZG5", "Dell Inspiron Mini 910" and "Samsung R730".

While on PC "ACER ASpire 5920" the Live Pendrive does not boot, after GRUB I get a black screen, in VGA (Safe mode) mode I get error "ATA04" ata_WaitBusuyTO: IRQ mode

With 20201110-2 on all 4 PCs the pendrive worked fine and the Mouse arrow was also clearly visible.

Will re-test the 3 PCs with your latest Build D5
D
deadwoodAROS Dev
Posted 4 months ago
For the "ACER ASpire 5920", does adding "noacpi" solve the boot problem?
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago

deadwood wrote:

@deadwood - For the "ACER ASpire 5920", does adding "noacpi" solve the boot problem?


No 'noacpi' does not solve it, even Build D5 has the same problem on 'ACER ASpire 5920'.
D
deadwoodAROS Dev
Posted 4 months ago
Can you try 64-bit ISO https://axrt.org/development/aros-pc-x86_64-alpha-6.zip on the ACER Aspire 5920?
Amiwell79Amiwell79Distro Maintainer
Posted 4 months ago
I can't try the builds at the moment I don't work the burner
D
deadwoodAROS Dev
Posted 4 months ago
@Amiwell79

Maybe you can install to pen drive under a VM and try booting pen drive?
Amiwell79Amiwell79Distro Maintainer
Posted 4 months ago
I tried VMware but it doesn't work for me I'll buy a burner thanks in the meantime
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago

Amiwell79 wrote:

@Amiwell79 - I tried VMware but it doesn't work for me I'll buy a burner thanks in the meantime


Strange VMWare is easy to install on Windows, try the free version "VMware Player", what kind of problems do you have installing VMware? what version of Windows are you using?

- Italiano -

Strano VMWare è facile da installare su Windows, prova la versione free "VMware Player", che tipo di problemi hai per installare VMware? che versione di Windows utilizzi ?
Amiwell79Amiwell79Distro Maintainer
Posted 4 months ago
I use windows 10 before it worked for me now no
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago

Amiwell79 wrote:

@Amiwell79 - I use windows 10 before it worked for me now no

Uninstall it and install it from scratch, try first an older version 7.x and then a new one.

Installing and testing with Pendrives is very fast, DVDs are a thing of the past, nobody installs with CDs/DVDs any more, long times and possible burning errors.

Also, when testing ISOs, with Pendrives you can replace files, with CDs/DVDs you have to burn a CD/DVD every time

--- Italiano ---

Disinstallalo e installalo ex-novo, prova prima con una versione più vecchia la 7.x e poi una nuova.

Installare e fare i test con le Pendrive è velocissimo, i DVD appartengono al passato, nessuno più installa con i CD/DVD, tempi lunghi e possibile errori di masterizzazione.

Inoltre quando testi le ISO, con le Pendrive puoi sostituire i file, con i CD/DVD ogni volta devi Masterizzare un CD/DVD
Amiwell79Amiwell79Distro Maintainer
Posted 4 months ago
I'll try as you say thank you
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago

With pc-x86_64-alpha-6, on "ACER ASpire 5920" I get a black screen, same thing with "ACER Aspire One ZG5", "Dell Inspiron Mini 910" I don't know if these two small netbooks support 64Bit

"Samsung R730". first the cat's eyes appear and then an error "Read Error -6 on block 0", I don't know if it's a defect of the Pendrive (I always use this pendrive for all tests) possibly I can try with another pendrive
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago
With pc-x86_64-alpha-6 i used a different Pendrive and the result was the same, even the error received on "Samsung R730" is the same "Read Error -6 on block 0",
D
deadwoodAROS Dev
Posted 4 months ago
@AMIGASYSTEM

Thanks for the tests, looks like a regression. Sad
D
deadwoodAROS Dev
Posted 4 months ago
@AMIGASYSTEM

What is the level of support of ACER Aspire 5920 with previous release? Are native graphics, sound and network card supported in AROS?
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 4 months ago
Unfortunately ACER 'Aspire 5920' with little compatibility

Video Mode = VESA
Audio = Recognised "hdaudio: HiFi 16 Bit Stereo" but no sound
WiFi = Not Supported (also tried other WiFi sheders I have at home, none are supported at the moment)
LAN = Not Tested

On ACER "Aspire 5920" AROS One x86 installs perfectly both from PenDriver and DVD

I add the compatibility of my other PCs

Netbook ACER Aspire One ZG5.
Video Card Supported = YES
Sound Card Supported = YES
WiFi Card Supported = YES
Touchpad Supported =YES
LAN = Not Tested

Netbook Dell Inspiron Mini 910.
Video Card Supported = YES
Sound Card Supported = YES
WiFi Card Supported = NO
Touchpad Supported = YES
LAN = Not Tested

Samsung R730
Video Card Supported = NO
VESA = YES
Sound Card Supported = YES
WiFi Card Supported = NO
Touchpad Supported = NO
Amiwell79Amiwell79Distro Maintainer
Posted 4 months ago


Ahi gives me a problem I attach an image, for the rest the system and the installed apps work, I have to try to install on HD because the previous versions only went with a flash drive

i.postimg.cc/GBvDQrWw/ahi.png
Edited by Amiwell79 on 04-11-2023 17:37, 4 months ago
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Users who participated in discussion: amigamia, deadwood, AMIGASYSTEM, pixie, retrofaza, Amiwell79, G-linx, OlafSch, d0wz
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 7
Members Online 0

Total Members: 214
Newest Member: Khadas
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]