Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

Cross/native compiling GCC in/for Aros

Last updated on 6 years ago
Posted 6 years ago

Okay, I have installed various Aros systems (Icaros, AspireOS, both Linux and Windows-hosted) variants. I am interested of making music Aros, working with another guy using old Amiga's, I write my own software, which I am trying to "port" to Aros. For that, I need SoX audio utility. I have tried to compile on Windows-hosted system, running Aros and compiling SoX from sources, but no luck so far. It is close, especially SoX version 12.17, compiles all to object files, but doesn't link the final binary. To do this, I have installed these packages of Aros:


No messages of missing anything, so it seems I have all needed, if not, any tips welcome :) !

Thanks !
cavemannSoftware Dev
Posted 6 years ago
A copy of serk's SoX build is in the upload section of the AROS-archive. You can get it there, or in a few days, it should be in the main archive :)
Edited by cavemann on 28-09-2018 21:43, 6 years ago
Posted 6 years ago
Cool, thanks very much, I struggled two days with native and cross-compiling, excellent news, already downloaded, testing now.

Thanks !!! :D !

Posted 6 years ago
OK, almost there, Sox works, installed few other utils, but the version is rather old, unfortunately, it seems I still need to find a way to native/cross compile some open source software (all command line/shell utils) to Aros.
cavemannSoftware Dev
Posted 6 years ago
Can't help with cross compiling, I use native only. Native seems easier to me, but I only build for x86.

Either way you should be getting a binary, or error messages. So what kind of errors are you getting?
Posted 6 years ago
Well, I am more interested to do native compiling too, and that's I have mostly done. So far I have only worked with SoX, old versions, got a binary, version 12.7.3, and it is too old, lacks features I need, so going some newer version next.

Various, as usually, configure works most of the cases, gcc runs and compiles object (.o) files, but problems start in linking all of them to final binary sox. I need to check some newer version, I can send some error messages I get, need to find exact version first.

Thanks !!
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Moderator: Administrator
Users who participated in discussion: cavemann, jp48
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 9
Members Online 0

Total Members: 242
Newest Member: JumpingKiwi
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]