Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

AROS ABIv0 20220318-1 Support

Last updated on 3 days ago
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 14 days ago

Amiwell79 wrote:

@Amiwell79 - deadwood dt2thumb do not works at moment used an old release and works


dt2thumb works fine, no problem creating thumbnails
D
deadwoodAROS Dev
Posted 14 days ago
Ok, I pushed changes to the repository. From next release, TheBar in contrib will be updated.
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 13 days ago
deadwood can you compile a script so that it transfers to an executable ?
I ask this because scripts with "S" flag will not work on FAT32 and DVD !
D
deadwoodAROS Dev
Posted 13 days ago
I'm not aware of any way of doing this. However running scripts work, at least on ISOs. Startup-Sequnce is a script as well as User-Startup.

Have you tried "Execute <script>" command?
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 13 days ago
Yes I always use execute "Script," but if you add the "S" flag, you don't need to use the Execute command, because it will still be used in a hidden manienra.

I am not referring to ordinary scripts like the startup sequence, but you have text files with the Flag "S", they basically work like .Bat files on Windows.

Any amigados script can be run if you add the "S" flag.

I made a small video showing what I mean, I used a Shell but you can run the script as an executable even from Wanderer !

And unfortunately on FAT32 and CDFilesystem the "S" flag is not supported !

That's why I was asking if you could compile the scripts, on OS3, OS4 and MOS there should be, I also remember that there is an amiga program "Picture To EXE", which converts a picture to an executable
You do not have access to view attachments
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 12 days ago
Today I tried installing AROS One 2.4 from Pendrive by adding the "S" flag to a text file (script), fiinished the installation I noticed that on the Hardisk the "S" flag had disappeared.

It seems that InstallAROS deletes the Flags during the copy phase, this should not happen because if there are scripts with the "S" flag in the system, these files once installedat would no longer work.


I don't remember reporting the ghost "icons" problem on Wanderer, that if you try to delete them, instead of being deleted they multiply, it is solved only if you delete the .backdrop file

Ghost icons appear for example when the .backdrop file is linked to a file that is no longer on the system.
D
deadwoodAROS Dev
Posted 12 days ago

AMIGASYSTEM wrote:

@AMIGASYSTEM - Today I tried installing AROS One 2.4 from Pendrive by adding the "S" flag to a text file (script), fiinished the installation I noticed that on the Hardisk the "S" flag had disappeared.

It seems that InstallAROS deletes the Flags during the copy phase, this should not happen because if there are scripts with the "S" flag in the system, these files once installedat would no longer work.


I created a new bug report: https://github.com/deadwood2/AROS/issues/136

AMIGASYSTEM wrote:


I don't remember reporting the ghost "icons" problem on Wanderer, that if you try to delete them, instead of being deleted they multiply, it is solved only if you delete the .backdrop file

Ghost icons appear for example when the .backdrop file is linked to a file that is no longer on the system.


I added this to existing bug report: https://github.com/deadwood2/AROS/issues/25
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 9 days ago
deadwood you could update the "ZIP" command included in the contrib, basically the ZIP command only compresses files and does not compress folders !
D
deadwoodAROS Dev
Posted 3 days ago
@AMIGASYSTEM

You need to add -r switch, for example:

zip -r ram:classes.zip sys:classes/#?

I tested this on AROS One 2.4
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 days ago
Ok it works I updated Dopus4, I was using the parameter -9
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Users who participated in discussion: deadwood, AMIGASYSTEM, Amiwell79
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 6
Members Online 0

Total Members: 209
Newest Member: Methanoid
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]