Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

AROS ABIv0 20220318 Development [CLOSED]

Last updated on 16 days ago
deadwoodAROS Dev
Posted 2 months ago

Here we go with next iteration. You know the drill ;)

Reference ISO: https://www.axrt.org/download/aros/v0/AROS-20211128-1-pc-i386-boot-iso.zip

First ISO moves us to 20211214 code base. There is only one notable change here, new C library. It's a big change though and essentially requires retesting all software to find out regressions.

Here is D01 ISO: https://axrt.org/development/AROS-20211214-D01-pc-i386-boot-iso.zip

The ISO contains core, contrib and Odyssey re-compiled to use the new C library. Big thanks to terminills for sharing his build machine which speeds up Odyssey build 2.5x times.

If you are integrating this ISO into your distribution and installation (so if you have "old" files), you need to delete some of them. I attach a script that shows which files to delete. Without deleting these files, the test results will be invalid. Note that deleting these files will make old Odyssey to stop loading. Best to keep two installations - reference and new system.

The most visible problems you can encounter after integrating is that some software will stop loading because stdc.library, stdcio.library or posixc.library is missing. Note that only software coming from AROS ISO should be using these libraries. The solution it to update the software with the version on the D01 ISO. If it happens that 3rd party (download from archives) software is reporting need for those libraries, be sure to let me know which.

Have fun :)

AROS ABIv0 20211214-D01 changes:

 Introduce new C library, synchronized with 64-bit AROS (deadwood)
 Allow linux hosted AROS to work under WSL (Kalamatee)


 Functional fixes:
 Wanderer (bugs: #107) (deadwood)
 fat-handler (bugs: #107) (deadwood)

 Stability fixes:

 64-bit/68k/ARM support:

Delete Libs:stdc.library
Delete Libs:stdcio.library
Delete Libs:posixc.library
Delete Libs:jfif.library
Delete Libs:jpeg.library

Delete Development:include/clib/arosc_protos.h
Delete Development:include/clib/posixc_protos.h
Delete Development:include/clib/stdcio_protos.h
Delete Development:include/clib/stdc_protos.h

Delete Development:include/define/arosc.h
Delete Development:include/define/posixc.h
Delete Development:include/define/stdcio.h
Delete Development:include/define/stdc.h

Delete Development:include/inline/arosc.h
Delete Development:include/inline/posixc.h
Delete Development:include/inline/stdcio.h
Delete Development:include/inline/stdc.h

Delete Development:include/libraries/posixc.h
Delete Development:include/libraries/stdcio.h
Delete Development:include/libraries/stdc.h

Delete Development:include/proto/arosc.h
Delete Development:include/proto/posixc.h
Delete Development:include/proto/stdcio.h
Delete Development:include/proto/stdc.h

Delete Development:lib/libarosc.a
Delete Development:lib/libposixc.a
Delete Development:lib/libstdcio.a
Delete Development:lib/libstdc.a
Edited by deadwood on 08-02-2024 05:31, 16 days ago
Amiwell79Amiwell79Distro Maintainer
Posted 2 months ago
ok deadwood try it for testing
Posted 2 months ago
Thanks deadwood, I'll get to work!

If I understand correctly, regarding your post "please delete", if you edit the post you should be able to delete the post, the "delete this post" appears
Posted 2 months ago
deadwood in the software included in Extras has something changed? does everything have to be overwritten?
Edited by AMIGASYSTEM on 21-12-2023 11:12, 2 months ago
deadwoodAROS Dev
Posted 2 months ago
There were no functional changes in contrib, but all the software has been recompiled to use new C library. If you don't update the software, you will start getting errors about missing stdc.library etc.
Posted 2 months ago
deadwood I have integrated 20211214-D01 on the new AROS One 2.4, at the moment everything is fine, I had to delete some Zune Libraries (.mcc/.mui) not included in your Build.

Noticed a problem on OWB (even with the default config), basically every time I start OWB in the folder where the Binary resides "empty" folders with strange names are created, see screenshot ! if I delete them on the next start a new folder is created, if I restart again a second strange folder is created !

Question: Inside the Extras folder there is a folder called 'GNU', should this folder remain in Extras, or can I integrate everything in Development?รน


There are duplicate catalogues 'catalonian' and 'catalan' (Spanish autonomous community)

I noticed that there are Scalos configurations in the ISO, has it been updated?
You do not have access to view attachments
Amiwell79Amiwell79Distro Maintainer
Posted 2 months ago
on the reference iso I tried the software in my distribution and it works I have not tried odyssey yet, I get output from applications written in freepascal amitube when I close it it gives me error dopus5 works
deadwoodAROS Dev
Posted 2 months ago

I also saw those weird empty directories. Something to investigate. There was no change to Scalos between last release (20211128-1 and this build). For GNU you can place it where you like, but it will always be in contrib in current location so you will have to manually synchronize it with each new build if you move it to other location.


You wrote that "on the reference" ISO.... Which ISO do you mean? The reference ISO is the current release.
Posted 2 months ago
OK thanks, it's not a problem to move, I do it with many other things, I just had some doubts in case the path was important.

The other day I had a strange thing happen to me, due to moving some files around, look at the attached video, it took me a few hours to realise the strangeness, in practice the problem only occurs the first time About AROS is run, after which it always works fine Smile Smile

Amiwell79Amiwell79Distro Maintainer
Posted 2 months ago
OK I'll try d01 I didn't understand
deadwoodAROS Dev
Posted 2 months ago
Has anyone been able to test new OWB binary? I can't seem to get youtube to work. All I get is page with placeholders of videos when navigating to main page. When trying a specific video, it loads for some time but never plays (and freezes OWCool.
Posted 2 months ago
I also have the same problem as you.

If you search for the video from Google and click on the image, the video gui opens and after a while you get the error you see in the screenshot, if you then go to the address bar and hit enter again, if it doesn't work you repeat it, this time the error doesn't appear. The video cannot be seen, but if you go with the cursor to the end of the video you will see the preview of the video image.

AmiTube is happy to download videos from YouTube!
You do not have access to view attachments
Amiwell79Amiwell79Distro Maintainer
Posted 2 months ago
deadwood i have tried and successfully installed the build in my acer aspire a110 native mode does not work vesa yes
Amiwell79Amiwell79Distro Maintainer
Posted 2 months ago
I encountered an error with owb during a third or fourth boot I don't remember now
You do not have access to view attachments
Amiwell79Amiwell79Distro Maintainer
Posted 2 months ago
the applications work however yes odyssey no longer plays videos and displays pages differently from the version running on the reference build
Posted 2 months ago

Some problems encountered with 20211214-D01

- FryingPan -> Does not work as it did in previous Builds
- DTConvert (Contrib Extras/Misc/Aminet) -> never worked (Does not convert anything)
- PlayMF (Extras/Misc/aminet7CAMD) -> never worked (Guru)

- OWB -> Uses 'CarbonPhyber' font by default and cannot be changed, does not work Preferences/Font, only works for size, cannot replace a font

- DiskImageGUI -> In Devs/DiskImage the Descriptors are missing:
- GI

If the Descriptor "CUE" is present in Devs/DiskImage if you send the command "Mount ICD0:" or run the DOSDrivers ICD0, you get a GURU.

About 'DiskImageGUI' to create the Guru is 'Diskimage.device'.

DiskImageGUI on Aros-Archive on the other hand works very well even if you use "CUE", it mounts CDs with the extension .cue without any problems

Continued .....
Amiwell79Amiwell79Distro Maintainer
Posted 2 months ago
after an installation on my netbook I wanted to create a usb key installation was not possible with the reference iso is possible
deadwoodAROS Dev
Posted 2 months ago
I don't know if installation to USB should be possible from anything else than Live-CD.

What goes wrong in your case?
deadwoodAROS Dev
Posted 2 months ago
Hmm, seems my post disappeared. To recap:

For descriptors in DiskImage you can't use previous descriptors as they often rely on stdc.library. If you use them with new build then most likely there will be a silent fail which will lead to guru.
Posted 2 months ago
I did numerous tests with all the old Descriptors and never had any GURU.

As said in the new Descriptors the important "CUE" is missing otherwise it is not possible to check in the ISO if there are Audio tracks !

With the Old Descriptors the "CUE" images are loaded correctly without any Guru.

On AROS One I am using "DiskImageGUI" from the new Build D01, I just replaced 'Diskimage.device'. which generated the GURU !

In practice, in order for 'DiskImageGUI' to work properly, the Descriptors must be in Devs/DOSDriver, so that all mounted devices appear in the GUI of 'DiskImageGUI'. With the old 'Diskimage.device' in system startup I never encountered Guru !
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Users who participated in discussion: serk118uk, magorium, deadwood, AMIGASYSTEM, pixie, retrofaza, Amiwell79, miker1264, Gundam
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 7
Members Online 0

Total Members: 209
Newest Member: Methanoid
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]