Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

AROS ABIv0 20201110

Last updated on 9 months ago
deadwoodAROS Dev
Posted 11 months ago
Here are release builds:


AROS ABIv0 20201110-2 changes:

  • Added broadcom4400.device network driver (Neil)
  • Extensions to IO-APIC support (Kalamatee)
  • Extensions to interrupt handling (Kalamatee)
  • Make native kernel more reselient in case of early error (deadwood)

64-bit support:

68k support:

ARM support:


Functional fixes:
  • fat-handler (Kalamatee, deadwood)
  • Prefs/Wanderer (bugs: window too wide) (Matthias Rustler)
  • GCC (bugs: sometimes generates non-loadable executables) (deadwood)
  • Kernel (bugs: wrong configuration of IRQ pins in IO-APIC) (deadwood)
  • Workaround for WARM reboot (deadwood)
  • Area.mui (bugs: events sent when not expected to) (deadwood)
  • Toolbar.mcc (bugs: broken binary compatibility) (deadwood)

Stability fixes:
  • Prefs/ScreenMode (deadwood)
  • DiskImageGUI (Kalamatee)

Unless some major problems are found, I will make the release official on Friday.
Edited by amigamia on 05-10-2023 20:31, 9 months ago
deadwoodAROS Dev
Posted 11 months ago
Hi All,

The release is now available:

With this action the development cycle for this release closes. There might be future fixes on a component level which will be announced in this thread. Thank you everyone who helped with testing - this all made this release better!

Enjoy this new version of AROS. Smile
Posted 11 months ago
I updated on Aros One the "WebPTools" to the new version 1.3.1 released today on Aminet, all binaries work fine except one "vwebp" where I get a Guru, see screnshot.

Also the previous version 1.3.0 hadvail command "vwebp" which went into lo Guru.
You do not have access to view attachments
deadwoodAROS Dev
Posted 11 months ago
Have you tried increasing stack to some large numbers, like 8 MB?

Was there version of AROS core in which the command did not guru?
Posted 10 months ago
Guru also appears with the build "AROS-20161228" and a high stack
deadwoodAROS Dev
Posted 10 months ago
Ok, for the time being I'll assume this is problem with software itself, not a regression in system.
Posted 10 months ago
I reported the Guru to the developer who responded to me saying:

Looks like the fault is in a buggy libopengl. In a recent aros built this seems excluded (because it's buggy ?).

Can't do too much here, except remove vwebp from the archive.
Edited by AMIGASYSTEM on 04-09-2023 06:27, 10 months ago
Posted 10 months ago
deadwood are there any new updates coming from you? otherwise i could post the new version of AROS One v2.2, since some new software came out, and many old Apps have been updated.

Question: I noticed that on your Builds there is always the old version of DiskImage v52.32, is there any reason why it is not updated to v52.34.

Version 52.34 can also be found on Aros Archive : http://archives.a...os.tar.bz2
deadwoodAROS Dev
Posted 10 months ago
There is no new core being worked on right now, so you can go ahead and release.

With regards to DiskImage (and other third party software in builds) it requires someone to update the source code in repository with new version for it to appear in builds. I guess no-one did this work.
Posted 10 months ago
AROS-20230929-pc-i386 (ABI-v1) and AROS-20230929-amiga-m68k include an 'intermediate' version v52.33 !
Posted 9 months ago

It has been reported to me HERE that German Keymap (pc105_d) is corrupt.

After some checking I found the corrupt file (not executable) I had copied it from your Build (don't know if also in previous builds), previous versions installed on my old AROS One work fine.
deadwoodAROS Dev
Posted 9 months ago
Thanks for reporting, I added it here: https://github.co.../issues/70

If I remember correctly there are fixes to the keymaps in master branch that were not yet pulled into ABIv0 branch. Once this happens I'll let you know.
Posted 9 months ago
Thank you, the keyboard problem was also present on my AROS One v2.1, in the attached forum they had discussed it a lot, I registered up and gave the right information! among other things, a very nice site in German/English Smile

Posted 9 months ago
I tested the AGet software, (simple application for testing HTTP servers, web based applications
and API's by sending plain HTTP protocol requests to a server svlupped in Holliwood), and I encountered a strange character after each string (see screenshot, probably a "formatting marks". The problem is also present on the Reverence Build.

In the OS3 version this problem does not exist, you can find AGet on Aminet here:

You do not have access to view attachments
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Users who participated in discussion: deadwood, AMIGASYSTEM
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 4
Members Online 0

Total Members: 242
Newest Member: JumpingKiwi
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]