Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

504 Gateway Timeout error

Last updated on 1 month ago
amigamiaamigamiaAdmin
Posted 1 month ago
Well things seem to get deeper as I try to dig this issue.

I was able to switch the PHP support from 8.3 back to 7.4 and while that resolved a bunch of warnings in the error log, it did not seem to do much to improve the sporadic latency.

What I have been experiencing is high latency when browsing but not to a specific page nor a specific time. Sometimes pages come up with no problem.

I checked the database and it's very small (6MB). I tried to optimize the tables, updated them ( I don't see an option to re-index on MariaDB). Nothing has changed from my code point.

I asked the hosting service to make sure arosworld.org was on the same server where ae.arosworld.org is and this is the response I got:

"Both ae.arosworld.org and arosworld.org are hosted on the same server. We are seeing no performance issues on our end.
Any issue you are still seeing will be the result of your site implementation rather than any server environment issue."


still working my way through this but I feel that at one point I may have to make a decision to switch to a more supported CMS. Waiting to see a supposedly new version of PHP-Fusion coming up. Stay tuned as I experiment and try things out.
D
deadwoodAROS Dev
Posted 1 month ago
Thanks for working on this issue Like
A
Amiwell79Distro Maintainer
Posted 1 month ago
thank you AmigamiaSmile
ArgoArgoNewbie
Posted 1 month ago
I keep getting this error " You are barred to post until the flood period cooldown is over. Please wait for now."

Haven't gotten the Gateway error in a few days
amigamiaamigamiaAdmin
Posted 1 month ago

Argo wrote:

@Argo - I keep getting this error " You are barred to post until the flood period cooldown is over. Please wait for now."


That's actually legit from a flood auto-ban but I am wondering why are you getting it? Are you posting really fast? It's there to protect from DoS attacks and spammers trying to flood the forums.

There is 30 seconds wait if it happens again. Also, let me know of the situation when it happens, (i.e. what was the action, etc.etc.)
A
Amiwell79Distro Maintainer
Posted 1 month ago
the site is working fine now thanksSmile
amigamiaamigamiaAdmin
Posted 1 month ago
I cleared the ngnix web service cache and removed an old site infusion that I wasn't using anymore. I noticed it too that it seems to be working better but I did not want to jump the guns. Thank you for reporting it.
ArgoArgoNewbie
Posted 1 month ago

amigamia wrote:

@amigamia -

Argo wrote:

@Argo - I keep getting this error " You are barred to post until the flood period cooldown is over. Please wait for now."


That's actually legit from a flood auto-ban but I am wondering why are you getting it? Are you posting really fast? It's there to protect from DoS attacks and spammers trying to flood the forums.

There is 30 seconds wait if it happens again. Also, let me know of the situation when it happens, (i.e. what was the action, etc.etc.)


Nope, I only made one comment on one topic yesterday and got that
D
deadwoodAROS Dev
Posted 1 month ago
FYI, yesterday was fine, but I'm getting long loading times today.
amigamiaamigamiaAdmin
Posted 1 month ago
Yeah it's not the database or the CMS. It is a shared hosting service which means aria world is not the only site at this address. This is server performance and they are just playing stupid.

Time to look elsewhere. I am going to perform an upgradeof the cms soon though. Just to make sure I have used all my options.
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Moderator: Administrator
Users who participated in discussion: amigamia, magorium, deadwood, Argo, AMIGASYSTEM, Amiwell79
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 4
Members Online 0

Total Members: 242
Newest Member: JumpingKiwi
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]