Print Thread
Cross/native compiling GCC in/for Aros
jp48
Hi,

Okay, I have installed various Aros systems (Icaros, AspireOS, both Linux and Windows-hosted) variants. I am interested of making music Aros, working with another guy using old Amiga's, I write my own software, which I am trying to "port" to Aros. For that, I need SoX audio utility. I have tried to compile on Windows-hosted system, running Aros and compiling SoX from sources, but no luck so far. It is close, especially SoX version 12.17, compiles all to object files, but doesn't link the final binary. To do this, I have installed these packages of Aros:

AROS-20180924-mingw32-i386-system
AROS-20180924-pc-i386-contrib

No messages of missing anything, so it seems I have all needed, if not, any tips welcome Smile !

Thanks !
 
cavemann
A copy of serk's SoX build is in the upload section of the AROS-archive. You can get it there, or in a few days, it should be in the main archive Smile
Edited by cavemann on 09/28/2018 16:43
 
jp48
Cool, thanks very much, I struggled two days with native and cross-compiling, excellent news, already downloaded, testing now.

Thanks !!! Grin !

Shock
 
jp48
OK, almost there, Sox works, installed few other utils, but the version is rather old, unfortunately, it seems I still need to find a way to native/cross compile some open source software (all command line/shell utils) to Aros.
 
cavemann
Can't help with cross compiling, I use native only. Native seems easier to me, but I only build for x86.

Either way you should be getting a binary, or error messages. So what kind of errors are you getting?
 
jp48
Well, I am more interested to do native compiling too, and that's I have mostly done. So far I have only worked with SoX, old versions, got a binary, version 12.7.3, and it is too old, lacks features I need, so going some newer version next.

Various, as usually, configure works most of the cases, gcc runs and compiles object (.o) files, but problems start in linking all of them to final binary sox. I need to check some newer version, I can send some error messages I get, need to find exact version first.

Thanks !!
 
Jump to Forum: